$re = '/.+(?:[^n]|[^i]n|[^b]in|[^.]bin)\.js$\n/m';
$str = 'file1.js
file2.src.js
file3.bin.src.js
file1.binbin.js
file1.in.js
file1.b.js
But not:
file1.bin.js
file2.src.bin.js
bla.js
.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);