const regex = /.+(?:[^n]|[^i]n|[^b]in|[^.]bin)\.js$\n/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+(?:[^n]|[^i]n|[^b]in|[^.]bin)\\.js$\\n', 'mg')
const str = `file1.js
file2.src.js
file3.bin.src.js
file1.binbin.js
file1.in.js
file1.b.js
But not:
file1.bin.js
file2.src.bin.js
bla.js
.js`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}