using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"NL\s?\d{2}\s?[A-Z]{4}[0 ]\s?\d{9}$";
string input = @"IBAN NL 91ABNA0417164300
IBAN NL91ABNA0417164300
Iban: NL 69 ABNA 401022366";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}