// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)NL\s?\d{2}\s?[A-Z]{4}[0 ]\s?\d{9}$").unwrap();
let string = "IBAN NL 91ABNA0417164300
IBAN NL91ABNA0417164300
Iban: NL 69 ABNA 401022366";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}