re = /NL\s?\d{2}\s?[A-Z]{4}[0 ]\s?\d{9}$/m
str = 'IBAN NL 91ABNA0417164300
IBAN NL91ABNA0417164300
Iban: NL 69 ABNA 401022366'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end