import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "NL\\s?\\d{2}\\s?[A-Z]{4}[0 ]\\s?\\d{9}$";
final String string = "IBAN NL 91ABNA0417164300\n"
+ "IBAN NL91ABNA0417164300\n"
+ "Iban: NL 69 ABNA 401022366";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}