const regex = new RegExp('NL\\s?\\d{2}\\s?[A-Z]{4}[0 ]\\s?\\d{9}$', 'gm')
const str = `IBAN NL 91ABNA0417164300
IBAN NL91ABNA0417164300
Iban: NL 69 ABNA 401022366`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}