package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)NL\s?\d{2}\s?[A-Z]{4}[0 ]\s?\d{9}$`)
var str = `IBAN NL 91ABNA0417164300
IBAN NL91ABNA0417164300
Iban: NL 69 ABNA 401022366`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}