package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*`)
var str = []byte(`https://client-eastwood-hue-prod-us.appspot.com.com.som.test/test/`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}