import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.[[:alnum:]]*\\.?[[:alnum:]]*\\.?[[:alnum:]]*\\.?[[:alnum:]]*\\.?[[:alnum:]]*";
final String string = "https://client-eastwood-hue-prod-us.appspot.com.com.som.test/test/";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}