// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\.[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*").unwrap();
let string = "https://client-eastwood-hue-prod-us.appspot.com.com.som.test/test/";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}