import re
regex = re.compile(r"\.[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*")
test_str = "https://client-eastwood-hue-prod-us.appspot.com.com.som.test/test/"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)