using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[a-zA-Z])([\d]+)(?=[a-zA-Z])(?=(?:[^~]*~[^~]*~[^~]*)*$)";
string substitution = @" $1 ";
string input = @"5n7x Jahalducro) ~P4J99UMH9~ (MD) auntud C D T)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}