import re
regex = re.compile(r"(?<=[a-zA-Z])([\d]+)(?=[a-zA-Z])(?=(?:[^~]*~[^~]*~[^~]*)*$)")
test_str = "5n7x Jahalducro) ~P4J99UMH9~ (MD) auntud C D T)"
subst = " $1 "
result = regex.sub(subst, test_str)
if result:
print(result)