const regex = /(?<=[a-zA-Z])([\d]+)(?=[a-zA-Z])(?=(?:[^~]*~[^~]*~[^~]*)*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[a-zA-Z])([\\d]+)(?=[a-zA-Z])(?=(?:[^~]*~[^~]*~[^~]*)*$)', 'g')
const str = `5n7x Jahalducro) ~P4J99UMH9~ (MD) auntud C D T)`;
const subst = ` $1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);