use strict;
my $str = '5n7x Jahalducro) ~P4J99UMH9~ (MD) auntud C D T)';
my $regex = qr/(?<=[a-zA-Z])([\d]+)(?=[a-zA-Z])(?=(?:[^~]*~[^~]*~[^~]*)*$)/p;
my $subst = ' $1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";