$re = '/(?<=[a-zA-Z])([\d]+)(?=[a-zA-Z])(?=(?:[^~]*~[^~]*~[^~]*)*$)/';
$str = '5n7x Jahalducro) ~P4J99UMH9~ (MD) auntud C D T)';
$subst = " $1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;