import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([^>\\s]+)[^>]*>(?:\\s*(?:br \\/>| | | | | | | | )\\s*)*<\\/\\1>";
final String string = "<td><img width=\"100%\" style=\"padding-bottom: 5px;\" src=\"http://portalvhdsy6f8km33yt638.blob.core.windows.net/mediacontainer/20150827-GLC-header.gif\" alt=\"\" /></td><b > </b>\n\n"
+ "<br />\n"
+ "<b> </b>\n"
+ "<p></p>\n"
+ "<td><br /></td>\n"
+ "<td></td>\n\n\n"
+ "CLEARLY CONFUSED HERE:\n"
+ "<b><br /></b>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}