const regex = /<([^>\s]+)[^>]*>(?:\s*(?:br \/>| | | | | | | | )\s*)*<\/\1>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<([^>\\s]+)[^>]*>(?:\\s*(?:br \\\/>| | | | | | | | )\\s*)*<\\\/\\1>', 'gm')
const str = `<td><img width="100%" style="padding-bottom: 5px;" src="http://portalvhdsy6f8km33yt638.blob.core.windows.net/mediacontainer/20150827-GLC-header.gif" alt="" /></td><b > </b>
<br />
<b> </b>
<p></p>
<td><br /></td>
<td></td>
CLEARLY CONFUSED HERE:
<b><br /></b>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);