#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\d]+(?:,\d+)*(?:\-\d+)?$"
Local $sString = "34343" & @CRLF & _
"4545454" & @CRLF & _
"5454,44.44" & @CRLF & _
"343445,55,55.55" & @CRLF & _
"3445," & @CRLF & _
"4545" & @CRLF & _
"54.54" & @CRLF & _
"545." & @CRLF & _
"545,545." & @CRLF & _
"5454.54," & @CRLF & _
"5454.54,55" & @CRLF & _
"........" & @CRLF & _
",,,," & @CRLF & _
"4444,54,54.55"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")