const regex = /^[\d]+(?:,\d+)*(?:\-\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\d]+(?:,\\d+)*(?:\\-\\d+)?$', 'gm')
const str = `34343
4545454
5454,44.44
343445,55,55.55
3445,
4545
54.54
545.
545,545.
5454.54,
5454.54,55
........
,,,,
4444,54,54.55`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}