import re
regex = re.compile(r"^[\d]+(?:,\d+)*(?:\-\d+)?$", flags=re.MULTILINE)
test_str = ("34343\n"
"4545454\n"
"5454,44.44\n"
"343445,55,55.55\n"
"3445,\n"
"4545\n"
"54.54\n"
"545.\n"
"545,545.\n"
"5454.54,\n"
"5454.54,55\n"
"........\n"
",,,,\n"
"4444,54,54.55")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")