$re = '/^[\d]+(?:,\d+)*(?:\-\d+)?$/m';
$str = '34343
4545454
5454,44.44
343445,55,55.55
3445,
4545
54.54
545.
545,545.
5454.54,
5454.54,55
........
,,,,
4444,54,54.55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);