package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\d]+(?:,\d+)*(?:\-\d+)?$`)
var str = `34343
4545454
5454,44.44
343445,55,55.55
3445,
4545
54.54
545.
545,545.
5454.54,
5454.54,55
........
,,,,
4444,54,54.55`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}