// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\d]+(?:,\d+)*(?:\-\d+)?$").unwrap();
let string = "34343
4545454
5454,44.44
343445,55,55.55
3445,
4545
54.54
545.
545,545.
5454.54,
5454.54,55
........
,,,,
4444,54,54.55";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}