#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z\d]+(?=([-_])?)(?:\1[a-zA-Z\d]+)*$"
Local $sString = "-test" & @CRLF & _
" : false " & @CRLF & _
"test-" & @CRLF & _
" : false" & @CRLF & _
"te--st" & @CRLF & _
" : false" & @CRLF & _
"test" & @CRLF & _
" : true" & @CRLF & _
"test-test" & @CRLF & _
" : true " & @CRLF & _
"te-st-t" & @CRLF & _
" : true " & @CRLF & _
"te-st_test" & @CRLF & _
" : false" & @CRLF & _
"te_st_test" & @CRLF & _
" : true"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")