$re = '/^[a-zA-Z\d]+(?=([-_])?)(?:\1[a-zA-Z\d]+)*$/m';
$str = '-test
: false
test-
: false
te--st
: false
test
: true
test-test
: true
te-st-t
: true
te-st_test
: false
te_st_test
: true';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);