using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z\d]+(?=([-_])?)(?:\1[a-zA-Z\d]+)*$";
string input = @"-test
: false
test-
: false
te--st
: false
test
: true
test-test
: true
te-st-t
: true
te-st_test
: false
te_st_test
: true";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}