import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z\\d]+(?=([-_])?)(?:\\1[a-zA-Z\\d]+)*$";
final String string = "-test\n"
+ " : false \n"
+ "test-\n"
+ " : false\n"
+ "te--st\n"
+ " : false\n"
+ "test\n"
+ " : true\n"
+ "test-test\n"
+ " : true \n"
+ "te-st-t\n"
+ " : true \n"
+ "te-st_test\n"
+ " : false\n"
+ "te_st_test\n"
+ " : true";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}