re = /^[a-zA-Z\d]+(?=([-_])?)(?:\1[a-zA-Z\d]+)*$/m
str = '-test
: false
test-
: false
te--st
: false
test
: true
test-test
: true
te-st-t
: true
te-st_test
: false
te_st_test
: true'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end