#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)0x[\da-f]+\s"
Local $sString = "Hi there to find hexadecimal codes;" & @CRLF & _
"0xff" & @CRLF & _
"0x342ax <- Invalid!" & @CRLF & _
"0xaab" & @CRLF & _
"a122 <- Invalid"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")