// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)0x[\da-f]+\s").unwrap();
let string = "Hi there to find hexadecimal codes;
0xff
0x342ax <- Invalid!
0xaab
a122 <- Invalid";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}