using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0x[\da-f]+\s";
string input = @"Hi there to find hexadecimal codes;
0xff
0x342ax <- Invalid!
0xaab
a122 <- Invalid";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}