const regex = /0x[\da-f]+\s/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0x[\\da-f]+\\s', 'gmi')
const str = `Hi there to find hexadecimal codes;
0xff
0x342ax <- Invalid!
0xaab
a122 <- Invalid`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}