re = /0x[\da-f]+\s/mi
str = 'Hi there to find hexadecimal codes;
0xff
0x342ax <- Invalid!
0xaab
a122 <- Invalid'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end