$re = '/0x[\da-f]+\s/mi';
$str = 'Hi there to find hexadecimal codes;
0xff
0x342ax <- Invalid!
0xaab
a122 <- Invalid';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);