using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bOU=[^,]+";
string input = @"CN=DAVID Jean Louis (a),OU=Coiffeur,OU=France,DC=Paris,DC=France
CN=PROVOST Franck,OU=Coiffeur,OU=France,DC=Paris,DC=France
CN=SZHARCOFF Michel (AB),OU=Coiffeur_Inter,OU=France,DC=Paris,DC=France";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}