import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bOU=[^,]+";
final String string = "CN=DAVID Jean Louis (a),OU=Coiffeur,OU=France,DC=Paris,DC=France\n"
+ "CN=PROVOST Franck,OU=Coiffeur,OU=France,DC=Paris,DC=France\n"
+ "CN=SZHARCOFF Michel (AB),OU=Coiffeur_Inter,OU=France,DC=Paris,DC=France";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}