const regex = /\bOU=[^,]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bOU=[^,]+', 'gm')
const str = `CN=DAVID Jean Louis (a),OU=Coiffeur,OU=France,DC=Paris,DC=France
CN=PROVOST Franck,OU=Coiffeur,OU=France,DC=Paris,DC=France
CN=SZHARCOFF Michel (AB),OU=Coiffeur_Inter,OU=France,DC=Paris,DC=France`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}