package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bOU=[^,]+`)
var str = `CN=DAVID Jean Louis (a),OU=Coiffeur,OU=France,DC=Paris,DC=France
CN=PROVOST Franck,OU=Coiffeur,OU=France,DC=Paris,DC=France
CN=SZHARCOFF Michel (AB),OU=Coiffeur_Inter,OU=France,DC=Paris,DC=France`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}