$re = '/\bOU=[^,]+/m';
$str = 'CN=DAVID Jean Louis (a),OU=Coiffeur,OU=France,DC=Paris,DC=France
CN=PROVOST Franck,OU=Coiffeur,OU=France,DC=Paris,DC=France
CN=SZHARCOFF Michel (AB),OU=Coiffeur_Inter,OU=France,DC=Paris,DC=France';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);