re = /\bOU=[^,]+/m
str = 'CN=DAVID Jean Louis (a),OU=Coiffeur,OU=France,DC=Paris,DC=France
CN=PROVOST Franck,OU=Coiffeur,OU=France,DC=Paris,DC=France
CN=SZHARCOFF Michel (AB),OU=Coiffeur_Inter,OU=France,DC=Paris,DC=France'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end