package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<match>(?'nine'9|0|18|27|36|45|54|63|72|81))`)
var str = `0
9
18
27
36
45
54
63
72
81`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}