$re = '/(?<match>(?\'nine\'9|0|18|27|36|45|54|63|72|81))/m';
$str = '0
9
18
27
36
45
54
63
72
81';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);