import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<match>(?'nine'9|0|18|27|36|45|54|63|72|81))";
final String string = "0\n"
+ "9\n"
+ "18\n"
+ "27\n"
+ "36\n"
+ "45\n"
+ "54\n"
+ "63\n"
+ "72\n"
+ "81";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}