import re
regex = re.compile(r"(?<match>(?'nine'9|0|18|27|36|45|54|63|72|81))", flags=re.MULTILINE)
test_str = ("0\n"
"9\n"
"18\n"
"27\n"
"36\n"
"45\n"
"54\n"
"63\n"
"72\n"
"81")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")