const regex = /(?<match>(?'nine'9|0|18|27|36|45|54|63|72|81))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<match>(?\'nine\'9|0|18|27|36|45|54|63|72|81))', 'gm')
const str = `0
9
18
27
36
45
54
63
72
81`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}