using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:""|(\d+),)|(\.\d+)""(?=,)";
string substitution = @"\1\2";
string input = @".""123,456,789,012.999"",";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}