use strict;
my $str = '."123,456,789,012.999",';
my $regex = qr/(?:"|(\d+),)|(\.\d+)"(?=,)/p;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";