const regex = /(?:"|(\d+),)|(\.\d+)"(?=,)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:"|(\\d+),)|(\\.\\d+)"(?=,)', 'g')
const str = `."123,456,789,012.999",`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);